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COMPUTER

Ch-1 (Computer- A Smart Machine )
Upskills your intelligence
A, Doityourself

1. a. Machine 2. b. Electronic machine 3. c. Computer 4. b. Desktop
5. ¢. Car

C. 1. Electronic Machine 2. Manual Machine 3. Fuel Machine
1. False 2. True 3. False 4. True 5. False

Critical Thinking
1. Desktop 2. Tablet 3.AC
1. Machines 2. Manual 3. Computer 4. Laptop
Team work
A. Do it yourself
B. Do it yourself
C. 1.Desktop 2. Laptop 3. Tablet
Ch-2 (Utilization of a Computer )
Upskills your intelligence
A.  l.c.Machine 2.a. Attending online class 3. b. Locations 4. c. Office

5. b. Electronic

1. Letters 2. Games 3. Songs 4. Daily 5. Customer's
C. 3. Calculate 4. Play songs 6. Type letters
D. 1. False 2. True 3. False 4. True 5. True

Critical Thinking
A. 1. Play games 2. Taking online classes 3. Making customer's bill
4. Type letters
B. 1. Home 2. Sums 3. Hospital 4. Laptop 5. Shop
Team work
Do it yourself
Ch-3 (Components of a Computer)
Upskills your intelligence

A. 1.aMachine 2.d. Visual Display Unit 3.b.CPU 4. a. centre
5. d. Speaker

B. 1. Different 2. Type 3. Keys 4. Mouse 5. Flash

c. 1P 2.M 3 M 4. K 5.8
6.C

D. 1. False 2. True 3. True 4. False 5. True
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Critical thinking

1. Mouse 2. Pendrive 3. Keys 4. Printer
1. Pen drive 2. Keyboard 3. CPU 4. Speaker
Team work

Do it yourself
Ch-4 (Significance of keys On a keyboard )
Upskills your intelligence

1. Caps lock 2. 104 3.26
4. Space bar key 5. Backspace

1. Two 2.26 3. 104

I. b.Numeric 2.c.4 3. a. Spacebar 4. c. Keys
1. False 2. True 3. False
4. False 5. False

Critical Thinking

Do it yourself

Down

1. Space bar

2. Alphabet keys

3.Cursor

Across

4. Arrow keys
5. Delete
Team work
Do it yourself
Ch-5 (Operating a mouse )

Upskills your intelligence

l.c. Wheel 2.b.Right 3.a. Two 4. a. Carries
5. b. Draw pictures

1. Cursor 2. Mouse 3. Wireless mouse 4. Mouse pad
1. False 2. False 3. True 4. True

5. True

1. Click 2. Draw 3. Arrow 4. Page up

Critical Thinking

1. Mouse 2. Scroll wheel

1. Input 2. Mouse 3. Cursor 4. Button
Team work

Do it yourself

5. Monitor
5. Mouse

5. b. Enter
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Ch-6 (Computer lab étiquettes )
Upskills your intelligence

Do it yourself

1. Yes 2. No 3. No 4. Yes
1. True 2. False 3. True 4. True
5. True

1. Remove your shoes before you enter the Computer lab.
2. Always wait in line to enter the computer lab.
3. The computer lab is not a place to run.
4. Touch the computer with clean hands only.
Critical thinking
1. Wires 2, Computer 3. Keys 4. Lab
Do it yourself
Team work
Do it yourself
Ch-7 (Storage Devices )
Upskills your intelligence

1. Laptop 2. Refrigerator

3.CPU 4. Data or Information

5. Hard disk

1. False 2. False 3. False 4. True 5. True

I. Data card 2. Hard disk 3. Pen drive

1. a. Files 2. b. Cupboard 3.a. Data 4.b. CPU 5. a. Byte

Critical Thinking

1. DATA

2. COMPUTER

3. MEMORY

4. INFORMATION

5. DEVICE

l. Storage device 2. Library 3. Cupboards 4. School Bag
Team work

Do it yourself
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Ch-1 (learning More About A Computer )
Upskills your intelligence
A. 1. Super Computer 2. Tablet Computer 3. Desktop Computer
4. Laptop Computer
1. b. Pocket computer 2. a. electronically 3. b. Tablet 4. b. Smaller
5. a. Workstation
1. False 2. False 3. True 4. False 5. False

o

A. 1. A computer is an electronically operated machine that helps us to do various
tasks. A computer can complete any task very quickly and efficiently.

2. A Tablet computer is a flat, thin computer whose size is smaller than a laptop
computer. It has a touchpad instead of a mouse. You can use your finger's motion
to work on a tablet.It is powered by a battery that can be recharged by a charger
and can be easily replaced.

3. Desktop Computer — A Desktop is a type of computer that can be placed easily on
a desk. It consists of a monitor attached with a keyboard, mouse and CPU. It can
also be referred to as Personal computer or PC.

A Desktop is a type of computer that can be placed easily on a desk. It consists of a
monitor attached with a keyboard, mouse and CPU. It can also be referred to as
Personal computer or PC.

Laptop computer- A Laptop is a type of computer that can be easily placed on a lap
to work. The size of a laptop computer is much smaller than a desktop computer.It

is highly portable.

4. Men Computer

Humans are living beings. Computers are non living machines

Humans get tired Computers do not get tired.

Humans cannot work for long hours. Computers can work for long hours.
Critical Thinking

A. 1. Machine

2. Power supply

3. Desktop
4. Computer
5. Laptop

B. Do it yourself
Team work
Do it yourself
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Ch-2 (Computers around us )
Upskills your intelligence
Do it yourself
1. Powerpoint 2. Railway Stations and Airports 3. Airports 4. Goods
5. Schools
1. True 2. False 3. True 4. False 5. True
Critical Thinking

1. Schools, Railway Stations, Airports, Shopping Malls, Medical Field and Banks.
2. (i) Interactive learning apps and virtual classes using smart classrooms.
(i1) Tracking performance of students
3. In hospitals, we use computers to maintain health records of patients.
4. At airports and stations, computers performs following tasks:
e To track and control the activities of aeroplanes in airways.
e Todisplay information about timings.
e To make or cancel reservations and booking and printing of tickets.
Critical thinking
1. Email 2. Records 3, Tickets 4. Engineer
Do it yourself
Team work
Do it yoursell
Ch-3 (Parts of A computer)
Upskills your intelligence
Input- Joystick, Microphone, Keyboard.
Output- Monitor,
Storage- Hard disk, Pen drive, DVD,
1.b. CPU 2.c. Printer 3.c. Storage 4.a. Monitor 5.a. CPU
1. is an input device 2. can play music 3. can transfer data between devices.
4. is an output device
1. The devices which are used to enter data into the computer are called input
devices. Examples:- . Keyboard, Mouse.

2.
Storage Output device
Storage devices are the hardware The devices which are used to
devices which allow storing data and display,print and show the results
M after processing are called output
applications. devices.
Monitor, printer and speakers are the Hard Disk,DVD and Pendrive are
most important output devices. the most important storage devices.

Because It controls the functioning of all the other parts of the computer.
Critical thinking

1. JOYSTICK

2. PENDRIVE

3. INPUT DEVICE

4. SPEAKER
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1. Mouse 2. Keyboard 3. Monitor 4. Speaker 5.CpPU
Team work
Do it yourself

Ch-4 (Working of a Computer)

Upskills your intelligence

Do it yourself

1. b. Process 2. c. Accuracy 3. b. Output 4. a. Mistake 5. b. Monitor

1. The running of multiple programs (sets of instructions) in one computer at the
same time.

2. Example:- making of mixed fruit juice Now, in the above example,the
ingredients required to make the juice like apple,pineapple,orange and
pomegranate are the input,the process will be placing all the ingredients into a
juicer jar and the output will be a glass of fresh mixed fruit juice. Similarly, to
perform any task, a computer has to go through the following three

processes:

INPUT PROCESS OUTPUT

These 3 processes together are called IPO.

3. Speed: A Computer is a very fast device. It is capable of processing a large

amount of data in very less time.

Storage: A Computer has much more storage capacity than humans.It can store

videos, text,audio in large amounts.

Reliability: A Computer is a reliable machine and designed to make maintenance

easy
4. Poor eyesight and lack of intelligence are the disadvantages of a computer.
1. False 2. True 3. True 4. False

Critical thinking

1. DILIGENCE

2. POOR EYESIGHT
3. STORAGE

4. MULTITASKING
Do it yoursell

Team work

Do it yourself
Ch-5 (Working of a Computer)

Upskills your intelligence
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1. Paint 2. Colour palette 3. Straight lines 4. Fill
5. Canvas
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1. a. Text tool 2. a. Magic 3. b. Colours 4. a. File
5. a. Letters
1. Step 1:- Click on the start button.
Step 2:- Select all programs
Step 3:- Click on the tux paint option either full screen or window.
2. Canvas/Drawing area, Color palette, Selection tools, Drawing tools.
3. This tool fills the picture with a colour.It is found in the magic effects option.
4. Magic tool offers a variety of unique effects such as 'blurring' and fading' for

drawings.
Critical thinking
1. Stamp tool 2. Paint tool 3. Text tool 4. Fill tool
1. Magic tool 2. Magic tool 3. Shape tool 4. Shape tool
Team work

Do it yoursell
Ch-6 (Introduction to ms word)
Upskills your intelligence

1. Tab 2. Document 3. Title 4. Control
1. False 2. True 3. False 4. False
5. True

1. A word processor is a software that processes words, paragraphs and pages and is
used for typing,saving and printing text documents.

2. Step 1:- Click on the file option available on the left top end corner of the screen.

Step 2:- Select the save option from the available options.

Step 3:- A box will appear, in which you can type the file name.

Step 4:- Type the file name and click on the save option.

3. Saving a file is very important. When we save a file, it can be used later to work
on it. We should always save a file before closing it.

4. Formatting the text in MS WORD includes changing the font, bolding the text

and changing the font colour and size.

1. d.Take the print out 2. d. Facebook 3. a. Save 4. a ll
5.a. Bar

Critical thinking

l.c. 2.4d. 3.b. 4. a.

1. Font style 2. Font size 3. Font colour

Team work

Do it yourself
Ch-7 (Working with a computer)
Upskills your intelligence

1. Button 2. Time 3. Booting up 4. Desktop

l.c. 2.a 3.d. 4.b.

l.c. Memory 2.a. Images 3.a. Lower left 4. c. CPU

Critical thinking

1. SCREEN 2.CPU 3. ICON 4. BOOTING 5. DESKTOP
CPU, UPS, Printer

Team work

Do it yoursell
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Ch-1 (Hardware and Software)
Upskills your intelligence

A. a.Pendrive b. DVD c. HArd drive d. Memory card
B. 1. System 2. Central processing unit 3. Printers
4. LED 5. Web camera

C. 1.The devices which are used to display,print and show the results after processing
are called output devices. Monitor, printer, speaker and projector are output
devices.

2. System software is designed to run a computer's hardware and provides a
platform for applications to run. E.g. Operating System An application is a
software that fulfils a specific need or performs tasks. Example : Paint, Excel,
Games, Word etc.

3. LED monitors have a better display. They are thinner and lighter in weight. They
consume 40 per cent less power than LCD.This is why LED monitors are more
economical than LCD monitors.

4. Memory card- It is a small chip-like device that stores electronic data. It can also
be inserted into a smartphone.

DVD- It stands for Digital Versatile Disk. It is used for data storage, recording, and

play audios and videos.

5. There are three types of printers Laser printer , Inkjet printer and Solid ink printer.

D. 1. Arithmetic and logic units 2. Digital Versatile Disk 3. Cathode Ray Tube

4. Light Emitting Diode 5. Liquid Crystal Display
E. 1.True 2. False 3. True 4. True 5. True
F. 1. Microsoft excel 2. ALU 3. Projector 4. CRT

5. Application
Critical thinking

A, 1LQWERTY 2 ALU 3. Monitor 4. Projector 5. CPU

B.  1.Output device 2. Input device 3. Output device 4. Input device
5. Output device 6. Input device 7.Input device
Team work

Do it yourself
Ch-2 (Classification of computers )
Upskills your intelligence

A.  1.Smartphone 2. Mini computer 3. Laptop computer
4. Desktop computer 5. Super computer
1. Micro 2. Hybrid 3. Tablet 4. Digital 5. Hybrid
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C. 1.Do it yourself

2. Mini computer are more expensive and more powerful than microcomputers. It is
a multi-threaded system. Mini computers are used in industries and for scientific
purposes.example of a mini-computer is PDP-8.

3. Supercomputers are the most powerful digital computers. They are capable of
handling huge amounts of calculations that are beyond human capabilities. They
are usually thousands of times faster than any other computer. They are used for
weather forecasting, space research and satellite control. An example of a
supercomputer is PARAM Brahma

4. DIGITAL COMPUTERS- These computers are the most commonly used. [t
calculates the numbers and do logical operations.

ANALOG COMPUTERS - An analog computer is a computer which is used to
process continuously changing data. They are used to measure and perform
arithmetic calculations of numbers, the length of an object etc.

5. Hybrid computers are complex computer units built using both analog and digital
properties and united by a single control system. These computers are used in
scientific applications, aeroplanes, ships, and hospitals.

1. True 2. True 3. False 4. False 5. True

1. Power 2. Laptop 3. Intensive Graphical Applications 4. Micro

5. Digital computers

E 1.€ 2.E 3.D 4. B 5. A

Critical thinking

A.  Desktop computer
B. Do it yourself
Team work

™ o

Do it yourself
Ch-3 (Learning about windows 10)
Upskills your intelligence

A. L. Start button 2. Cortana, run and search 3. Opened or pinned programmes
4. Date and time

B. 1. Graphical 2. Paid 3. Window taskbar
4. wallpaper and screen saver 5. Operating system

C. 1. Ability of a computer to carry out all of its functions depends on a unique set of
programs. These special sets of programs are known as the operating system
(OS). An operating system is a software that helps us to work on a computer
system. It is the most important part of the computer system. For e.g. Linux, GM
NAA, MAC, Android and Microsoft windows.

2.1. Desktop 2. lcons 3. Apps 4. Start button 5. Recycle bin
6. Windows taskbar

3. Calculator - The calculator is an app that performs arithmetic calculations such
as add, subtract and scientific calculations.

Notepad - Notepad is a basic text editing tool developed by Microsoft Windows, It
allows us to create, edit and print a document. We can also save a file in the Notepad
app.

4. Changing the Wallpaper:

Steps:

1. Right-click on empty space on the desktop. A shortcut menu will appear

2. Click personalise. This option is at the bottom of the drop-down menu.
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3. Click the box beneath the 'Background'. Select the desired picture.
5.Windows Media Player is an application that allows us to play audio,video files
and view images.
E. 1l.A 2.C 3.D 4. E. 5.A
Critical thinking
A. Recycle bin
B. 1. MAC 2. LINUX 3. GM-NAA
Team work
Do it yourself
Ch-4 (Text editing in microsoft word 2016)
Upskills your intelligence
A. 1. Microsoft Corporation. 2. Preview 3. Quick access toolbar
4. Command 5. Default
B. 1. The Title bar is next to the quick access toolbar. It shows the name of the
document which is opened. By default, the name of any new Word document is
Documentl.
2. Undo- Undo erases the last change done to the document, reverting it to an older
state. Redo— The redo command restores what we just did.
3. (1) It allows you to copy and move the text from one location to another.
(i) It permits you to create letters, resumes, and notices in an orderly manner.
(ii1) It lets you edit the text after typing.
4. We can select a paragraph in a document by clicking on a text section three times
with the left mouse button.
5. Zoom Slider component of MS Word allows you to zoom in or out of the

document.
C. 1. False 2. False 3. True 4. False 5. False
D. Lb. 2.d. 3.a. 4.c.
E. l QUICK ACCESS TOOL BAR RiiBEH
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Critical thinking
A. Do it yourself
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Team work
Do it yourself
Ch-5 (Formatting in ms word)

Upskills your intelligence

1. Formatting 2. Home 3. Font 4. Calibri 5. Justify

1. Features offered by MS Word to format the text are as follows.

e  Font style, size and colour’

e  Textcase and alignment '

e  Border and shading effect

A font refers to the size, design, colour and style of typed characters within a

document. To add variation to a document, we can use different fonts, such as

separate font styles for the heading and the body.

1. steps to change the font colour of the text.

Steps :

1. Select the text whose colour you want to change.

2. On the Home tab, click the Font Color drop-down arrow. The Font Color menu
appears.

3. With the help of the mouse, select the font colour you want to use. The font
colour will change for the selected text.

4. Your colour choices are not limited to the drop-down menu that appears. Select
More Colors at the bottom of the menu to access the Colors dialogue box. Choose
the colour you want, then click OK.

There are four alignments

Left align, Center align, Right align and Justify align

Follow the given steps to make the text Bold

Steps:

1. Select the text you want to bold.

2. On the Home tab, click the Bold (B)command in the Font group. Consider the
example; click Italics.

3. The selected text will be bold in the document.

1. False 2. True 3. False 4. True 5. True
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D. 1L.C 2.D 3.E 4.B 5.A
E. 1.Left 2. Font 3. ltalics 4. Underlining 5. Right
Critical Thinking
A 1.4 2:2 31 4.3
B. use justify alignment
Team Work
Do it yourself
Ch-6 (Using paint 3D )
Upskills your intelligence
A. 1. Menu 2. Classification 3. 2D shape 4. Twxt tool
5. 3D paint window
B. 1. The Title bar is next to the quick access toolbar. It shows the name of the
document which is opened. By default, the name of any new Word document is
Document].
2. Undo- Undo erases the last change done to the document, reverting it to an older
state. Redo— The redo command restores what we just did.
3. (i) It allows you to copy and move the text from one location to another.
(i) It permits you to create letters, resumes, and notices in an orderly manner.
(ii1) It lets you edit the text after typing.
4. We can select a paragraph in a document by clicking on a text section three times
with the left mouse button.
5. Zoom Slider component of MS Word allows you to zoom in or out of the
document.
C. 1.False 2. False 3. True 4. False 5. False
B, L, i D 3.a 4. c.
B @ Menu grysh 2 4 6 Text tool
-
§ canva
s -~
L —
Critical thinking
A.
2D shapes 3D shapes
a
b d
e
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C. B. steps to save a drawingin Paint 3D.
Steps:
1. Click Expand menu button.
2. Select the Save As option.
3. Type a name for your project.
4. Click the Save option.

5. Digital computers

Team Work

Do it yourself

Ch-7 (Introducing scratch 3.0)

Upskills your intelligence
A. 1. Scratch 2. Visual 3. Web 4. Title bar 5. Blocks
B. 1. Scratch is an excellent visual programming language where we can create

interactive narratives, games, and animations.

2. Features of scratch
Scratch is freely available on the web. !
The cartoon mascot of Scratch is a cat. !
For a story, we can design our characters. !

It can run well on various operating systems, including Windows, Linux, and
Mac OS.

3. The menu bar has a variety of menus and icons, including File, Edit, Tutorials,
etc.
4. Blocks for programming are found here. Drag the blocks to the script area from
the block palette.
5. steps to run the Scratch.
Steps :
1. Click on the start button.
2. Click the Scratch Application and its window opens.

C. 1. True 2. False 3. False 4. True 5. True
D. HEw = .""“
: E:g Sprite
o GIT=
: - Blocks g
* Coem Stage
¢ IR Block 2
= | =i
o] Script —
o)
[—-o]
o]
=
=== Add
= oo
E. 1. Stage 2. Cat 3. Web 4. Sprite 5. Add extension
Critical thinking
A. 1.BLOCKS 2.EXTENSIONS 3. SCRIPT 4. TITLE 5.STAGE
B, 2%

TEAM WORK - DO IT YOURSELF
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Ch-1 (Evolution of Computers)
A. 1. heaven and earth 2. advances 3. Universal Automatic Computer |
4. Analytical Engine 5. John Von Neumanna
B. 1. The feature of the abacus is that it was used to rapidly and easily conduct addition

and subtraction.

2

Arithmetic Machine Napier's Bones
This is also known as the Mechanical calculator Manually driven calculator
It made addition and subtraction easier. It made multiplication easier.

3. German scientist, Gottfried Wilhelm Leibniz created Stepped Reckoner
4. The similarity between ENIAC and UNIVAC [ is a general-purpose digital
computer.
5. The two features of Harvard Mark 1-
1.1t is also referred to as the Automatic Sequence Controlled Calculator

2.1t is a general-purpose electromechanical computer.

C. 1. Pascaline 2. Napier's Bones 3. Stepped Reckoner 4. ENIAC
5. Harvard Mark |

D. 1.T 2.T 3.F 4.T 5.F

E. 1d 2.a Jic 4.a 5b

Critical Thinking

A. 1. The german scientist, Gottfried Wilhelm Leibniz, created the stepped reckoner,
sometimes referred as the Leibniz calculator in 1672 and finished it in 1694,

B. 1.ENIAC

2.Pascaline

3.Napier's Bones

Team Work

Ask the students to do it themselves.

Ch-2 (Organising Files and Folders)

1.Cortana 2. Task view 3.icon 4. storage 5. pop-up
B. 1.Createafolder 2. Open File Explorer 3. Renamea folder

4. Delete a folder
C. 1.F 2.F 3F 4.T 5.T

l.c 2d 3b 4.c 5.b
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1. The three features of Windows 10 are-
1. Multiple users work on one computer system at the same time.
2. Italso provides the feature of downloading free and paid apps.
3. Itenables one to start more than one program ata time.

A folder serves as storage for files or other folders.

A context menu provides an option that can be accessed quickly.

1. Right-click on the folder or file that you want to rename.

2. Click on the “rename” option from the context menu.

3. Type the new name for the folder or file.

4. Press enter.

A file is a collection of data or information.

Critical Thinking

W oW

—_—

2
Team Work
Ask the students to do it themselves.
Ch-3 (More on Point 3D)

1.3D View 2. History slider 3.Paint 3D 43Dtext  5.canvas
1.2D Shapes 2.3D Library 3. Stickers 4.3D Library

5. Z-axis position tool

L.T 2.F 3.T 4.T 5.F

1.8 2.8 3.a 4.d 5.b

1. Itis a fantastic program that enables us to create either creative or professional
projects.
2. This text tool allows you to add 2D or 3D text options to your drawings.
3. Follow the given steps to apply stickers and textures.
Steps: 1. Select the 3D shapes tool.
2. Inthe 3D shapes panel, select the dog given under the category 3D models.
3. Select the sticker tool.
4. Add eyes and tongue stickers to the cat.
5. Zoomin on the cat's tail to add the fur texture.
6. Size and rotate the texture as desired.
4. The Brushes tool has different brush types, which are used to draw lines by hand in
various styles. It can be used to paint on both 2D and 3D surfaces.
5.3D View enables you to edit from any angle, which means even more accurate and
intuitive 3D creation. You can move around your 3D designs.
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Students will do it themselves.
Team Work
Students will do it themselves
Ch-4 (More on MS Word 2016)
1. order 2. Selecting 3. right 4. Editing 5.find
1.EditMenu 2. Editor Pane 3.FileMenu  4.Numbered List
5.Proofreading group
1E 2 3.T 4.T 5F
Copy, Printpreview,, paste, FindandReplace, Navigationpanel
1. The steps to move a text: can move around your 3D designs.
Select the text you want to move. 2. Click the “Cut” command on the Home tab.
Alternatively, you can press Ctrl+X on your keyboard. 3. Place your cursor point where
you want the text to appear. 4. Click the “Paste” command on the Home tab.
Alternatively, you can press Ctrl+V on your keyboard.
You can easily insert a special character, fraction, or other symbols, such as currency,
check marks, and many more symbols, in your Word documents.
Numbered List follows some order, while the bulleted list doesn't.
Select the text you want to copy.
The 'find' feature allows finding the word or particular text in the document, and the
‘replace’ feature allows you to replace it with the corrected or another word.
Critical Thinking
After you have done typing a section of text in Microsoft Word, you may need to move
it somewhere else. You can use the moving text option to correct the essay.
l.Insert
2.Home
3. Review
Team Work-
Students will do it themselves
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Ch-5 (Formatting features os MS Word 2016)

1. Character and Paragraph 2. Text 3. Insert 4. Word Art
5. Textbox

1.Doc 2. Word processing program 3.Cul+N 4. Save
5. Ctr+Z

LF 2.F 3T 4.T o i Iy

Horizontal data
Vertical Data
To combine two or more cells
Breaking of Multiple cells
Tochange the size
1. Styles means unique technique. Microsoft Word has a number of tools that can be
used to modify the document and give it amore attractive appearance by using various
shapes, images, text styles, etc. Character and paragraph styles are there in MS Word.
A Text Box is a placeholder where text can be typed in. If you want to resize the
text, select the text and change the font size on the Home tab.
Clip art is a set of images provided by Microsoft Office, that can be used in the
document. Word art is a stylish text style provided by Microsoft Office. Clipart is
animated pictures, and WordArt is like animated words.
WordArt 1s a text modifying feature in Microsoft Word with effects such as
shadows, outlines, colours, gradients, and 3D effects that can be added to a word or
phrase.
Shapes of all kinds, including boxes, rectangles, callouts, circles, arrows, lines,
triangles, curves, equation shapes, and many more, are available in MS Word.
Critical Thinking
Students will do it themselves
Team Work
Students will do it themselves

Ch-6 (More about Scratch 3.0)
1. blocks 2.Code 3.Bachdrop 4. Looks 5. White
1. The default value for the turn block is 15. This will rotate your sprite 15 degrees ina
clockwise direction, as shown by the arrow on the block.
2. Use Think hmm for 2 seconds to add a 'thinking cloud' to the Sprite.
3. This allows you to repeat a sequence of commands a particular number of times; you
set the number of times the loop will repeat at the top of the block.
LJF 2. 3T 4F 5F
lse 2b  3d 4.c 5.a
1. The use of Motion blocks: Motion Blocks are used to direct a sprite's movement on

stage.
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2. The pen block presents as an extension to the Scratch 3.0
3. The different blocks available in Scratch are Sound Block, Motion Block, Control
Block, Events Block, and Pen Block
4. 1. Click the sound block.
2. Select the play sound meow until done and drag this block and place it under the
Script Palette.
3. Run the code by clicking on the blocks in the Script area.
4. To stop all sounds being played on all sprites, use the stop all sounds block.
5.Follow the given steps to choose a backdrop for the sprite.
Steps: 1. Click on the Choose a Backdrop button.
2. Choose a Backdrop window appears.
3. From the preview list, select the Blue Sky backdrop. The Blue Sky backdrop at
the background of the Sprite will be added.
Critical Thinking

A. To stop all sounds being played on all sprites, use the stop all sounds block.

BlA|lZz | R |W/[[C]| I |WI|[E]|C
H L F M O X | V X
O | (S (0] ULtINN[ D)| P E R
H C Q E AT G N N K
v im[PINI[IR[[]U] O[T a
E X S | (L 0] 0] K S) J
D T L | WL)| S P K T
(M ®] T | o N) | V U B
Team Work
Students will do it themselves
Ch-7 (MS Powerpoint 2016)
A, l.slides. 2. Normal J3.Crl+N 4. pptx 5. Note
B. 1.Slideslayout 2.Zoom Control 3. Slide Pane 4. Quick Acces Toolbar
5.Slide Navigation Pane
€: LE 2T 3.T 4.F 5F
B le 2.a 3¢ 4.a 5b
E. 1.UsingaPowerPoint presentation has the following advantages: 1. Organise and
structure your presentation. 2. Animate your slide to enhance the visual impact.
2. Follow the given steps to change the layout.
Steps: 1. Click on the Home tab.
2. Inthe slides group, click on the Layout button.
3. Selectan appropriate layout for yourslide.
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3. There are different slide viewing options: Normal View: It is the default view in
which the selected slide is displayed, along with the slide navigation window. Slide
Sorter: [tdisplays smaller versions of all the slides in the presentation. Reading View:
In this view, we canreview slides more easily because all the modifying tools are

hidden in this. Slide Show: Slides from a presentation will be played through this.

4.
Slides Presentation
Aslide in PowerPoint is where PowerPoint is a popularapplication
information can be placed in the program that allows you to create
form of text, pictures, and show slides to supporta
sounds, animation, and much more presentation.

5. Aribbon is made up of Tabs and Groups. It has multiple tabs, each with several

groups of commands.

Critical Thinking
A.  a. Presentation b.Slides c.Reading d.Layout e.Ribbon
B. Follow the given steps to save a presentation.

Steps:

1. Click on the File tab.

2. Select the save or save as command and click on the Browse option.

3. The Save as dialogue box appears. Select the location of a file.

4. Give the name to the presentation.

5. Click on the Save button.

6. The presentation will be saved with an extension .pptx.

Team Work

Students will do it themselves

Ch-8 (More about Scratch 3.0)

A. 1.Slideshow 2.Normal, Slide Sorter 3.Presentation  4.formatbackground pane

5. Mouse

B. 1.Slide Show- Series of Slides 2. Font Colour- Default colour Black
3. Font Style- Times New Roman 4. FontSize-Arial 11
5. New Slide- Insert tab > New slide.

€. LF 2.F 3T 4.T 5.F

D. le. 2.b 3¢ 4.a 5.d
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E.

1. Follow the given steps to insert a new slide.
Steps:
1. Click on the Home tab. Opening a Presentation
2. From the slides group, click on the New slide.
3. Select the type of slide you want.
4. Anew side is inserted
2. The slide show is a series of slides that displays all the slides on the screen one by one.
3. The position of the pictures can be changed. Follow the given steps to change the
position of the picture.
Steps:
1. Click on the image.
2. Sizing handles will appear around the edges of the picture.
3. Move the mouse pointer over a sizing handle.
4. The shape of the cursor will change to a four-headed arrow.
5. While holding the mouse button, drag the mouse in the required direction.
6. Release the mouse once the picture is positioned.
4. Making changes in the text's appearance to make it more exciting and attention
grabbing is referred to as "formatting.
5. Follow the given steps to insert an image from a file.
Steps:
1. Take the cursor where you want to insert a picture on the slide.
2. Click on the Insert tab: click on the Pictures button in the Images group.
3. A dialogue box will appear.
4, Browse to the location where you have saved your picture file.
5. Select the desired picture and click the insert button.
6. The picture will appear on the slide.
Critical Thinking
2 4 31
Follow the given steps to add a background style using the theme options.
Steps:
1. Click the desired slide.
2. Click on the Design tab. In the Themes group, choose the themes you want
to apply
Team Work

Students will do it themselves.
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"OMPUTER

Ch-1 (Generations of computers)

A.  Fill in the Blanks

1. Abacus 2. Charles Babbage

3. Analytical Engine 4. Five

5. Integrated Circuits

B.  Write 'T' for True statements and 'F' for False statements
1. True 2. True 3. True 4. True 5. False
C. Answer in one word.
1.  RAM Read Only Memory 2. Digital Versatile Disc - DVD
3. Pen Drive 4.  ROM Random Access Memory
D. Write the following in expanded form.

1. ROM Random Access Memory

2. Read Only Memory

3.  Compact disc read-only memory (CD-ROM)

4.  Digital versatile disc

5. Very Large Scale Integration

E. Answer the following questions
[ [Rne =
i

2. The main electronic component — is the transistor.
Memory — magnetic core and magnetic tape/disk.
Programming language — assembly language.
Power and size — low power consumption, generated less heat, and smaller in size
(in comparison with the first generation computers).

3. The third generation of computers was produced between 1965 and 1971, and the
fourth generation was produced between 1971 and 1980. While fourth-generation
computers used VLSI technology or very large-scale integrated (VLSI) circuits,
third-generation computers used integrated circuits (1Cs).

4. The part of the computer's primary storage usually referred to as main memory,
stores data, programs, and instructions that are now being used. On the
motherboard is where the primary storage is. Data can be read from and written to
primary storage very quickly as aresult.
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5. Devices for Secondary Storage: Secondary storage is a memory that is kept off the
computer's main memory bus. It is mostly employed for the long-term, permanent
storage of programs and data. Secondary storage types include hard drives, CDs,
DVDs, Pen/Flash drives, SSDs, and more.

Critical Thinking

A. 1. Third Generation 2. Second Generation
3. Third Generation 4. Third Generation

Team Work

1. Artificial intelligence (Al) technology is used by computers in the fifth generation,
and it is used to create expert systems, play games, and more. Due to Al technology,
these machines could understand human language and identify graphs and
pictures.

2. Pen Drive and Hard Disks. Data backups from primary storage are frequently
kept in secondary storage. Replication or other data protection and recovery
procedures are used to copy the data from the primary storage system to the
secondary storage system.

Ch-2 (Learning More About Windows 10)
A.  Fillinthe Blanks

1. Operating System 2. 1995
3. Windows 10 4. Applications
5. Desktop
B. Answer in one word.
1. Icons 2. Desktop's Bottom
3. Start Button 4. Operating System

5. File Explorer Window
C. Write 'T' for True statements and 'F' for False statements
1. False 2. True 3. True 4. False 5. False

D. Identify the following icons/apps and write their names.

1. Shorteut lcon 2. Recycle Bin
3. Application lcon 4. This PC lcon
5. Weather App 6.  Email lcon

E.  Answer the following questions
1. The Start button is back.

Microsoft Edge replaces Internet Explorer, which experienced several security
issues last year.

Windows now offer a virtual assistant.
Security features have been significantly enhanced.

Upgrading is free (for one year)
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Control Panel: Allows users to view and change basic system settings and
controls, such as adding hardware, adding and removing software, controlling user
accounts, and changing accessibility options

Device Manager: Allows the user to display and control the hardware attached
to the computer, and control what device drivers are used

Change your desktop background image by

Selecting Start > Settings > Personalization > Background.

In the list next to Personalize your background, select Picture, Solid color, or
Slideshow. Change Wallpaper with pictures given on the desktop or download
pictures online.

A screensaver is a computer software that may be set to start when the user is
inactive for a certain amount of time (when you leave your computer). It was
originally intended to protect older monitors from harm, but it is now being
employed to stop users from accessing desktop material while they are away.

For accessing the file systems, it offers a graphical user interface. It is also the part
of the operating system that displays the taskbar and other user interface elements
on the screen.

Critical Thinking
A.  Start Button

B. 1. Universal App 2. Live Tiles 3. Desktop
4, TaskBar 5. Icons
Team Work

Ch-3 (Advance Features of MS Word)

A. Fillinthe Blanks

L,
3
5k

L.
3.

Microsoft Corporation 2. Character
Paragraphs and Characters 4. Ordered and Unordered
Below

B. Answer in one word.
M.S Word Style 2. superscript or subscript
Symbols and Shapes 4. Cul+Z
Quick Assess Toolbar

3,
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C. Write "T" for True statements and 'F' for False statements
1. False 2. True 3. False 4. True 5. False

D. Tick the correct answer.

L.

Thesaurus 2.  Shapes 3.  Layout Footer

E.  Answer the following questions

L.

Choose the text that needs formatting. The style is applied to the entire paragraph if
you place your cursor within one. To sample a style on the Home tab, point to it.
Click the More option if you don't see the style you're looking for. Choose a style.

A header is the top margin and a footer is the bottom margin of each page and is
helpful to separate sections from the main document. A footer is text that is
positioned at the bottom of a page, while a header is a text that is positioned at the
top of a page. Usually, details about the document, such as the title, chapter
heading, page numbers, and creation date, are inserted in these spaces.

A huge capital letter known as a drop cap (sometimes known as a dropped capital)
is used as a decorative element at the start of a paragraph or section. A drop cap is
often two or more lines in length.

A subscript is an integer that identifies a specific array element. Abbreviations
related to computers, fonts, programming, subscripts, superscripts, typography,
and word processors. Eg. CO2

On the Page Layout tab, in the Page Setup group, click Margins.
Click the margin type. For the most common margin width, click Normal.
You can specify your own custom margin settings.

Critical Thinking
B.  Write the firm name in a document with the formatting you want it to have.

Choose the business name. Press Alt + F3.

Change the text in the Name field to a brief mnemonic for your business name, such
as the initials of the organization, Pick AutoText from the Gallery drop-down menu.

Team Work
Students will do it themselves

Ch-4 (Mail Merge)

A. Fillinthe Blanks

1.
3.
8,

Mail Merge 2 Main Document and Data Source
Data Source 4. Mailing Tabs
Right Side

B. Answer in one word.

[V T TSI G

Mailing Tab

The main document, The data source, and The merged document.
Ok

Insert Merge

Preview Result Buttons

C.  Write 'T' for True statements and 'F' for False statements

1.

True 2. False 3. True 4. True 5. False
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D. Identify and Label the following buttons.
1. Mailing Tabs 2. File Tab 3. Mailing Merge
E.  Answer the following questions

1. Youcan use mail merge to customize a batch of documents for each recipient. One
way to personalize a form letter is to address each recipient by name. A data source
is connected to the document, such as a list, spreadsheet, or database.

2. Click Start Mail Merge and Step-by-Step Mail Merge Tab on the MAILINGS tab.
Click Next after selecting the type of document to which you wish to add mail
merging. Here, you can create a new document using an existing one or a template.

3. Simply said, a data source is where the data came from. A live data feed, a specific
database on a DBMS, or simply a file can be used. The data may be on the same
machine as the software or on a different machine connected to a network.

4. Adocument, spreadsheet, or database serving as the data source holds personally
identifiable data such as names, addresses, and phone numbers. A form letter,
labels, an email, ora directory could all be considered the main document.

5. Navigate to File > New > Blank Document. Select Recipients > Type a New List
from the menu. Enter the necessary recipient information in each column of the
New Address List dialogue box. See Edit Data Source for more details on how to
use the dialogue box.

Critical Thinking
Students will do it themselves
Team Work
Students will do it themselves
Ch-5 (Upgrading Presentation)
A. Fillinthe Blanks
1. Presentation 2. Placeholder
3. Smart Art Graphic or Info Graphics 4. Animation Effect
5. Transition Effect
B. Identify the following options in MS Powerpoint.

1. Inserting Shapes 2. Format Tab

3. Applying Smart Art 4. Animation Effect
C. Answer in one word.

1. Three 2. Format Tab

3. Transition 4. Transition

5. Illustration Group

D.  Write 'T' for True statements and 'F' for False statements
1. True 2. False 3. False 4. True 5. True
E.  Answer the following questions

1. When you switch from one slide to the next during a presentation, a slide transition
takes place. The pace, the sound, and the appearance of transition effects are all
customizable.

2. Click SmartArt under the lllustrations group on the Insert tab.
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Choose the type and arrangement you want by clicking them in the Choose a
SmartArt Graphic dialogue box.

Choose one of the following methods to enter your text: Type your text by clicking
[Text] in the Text pane.

3. Press Ctrl and select the objects you want. Select Format > Group > Group to
group the objects together. Select Animations and choose an animation.

4. Youcan flip, rotate, or resize PowerPoint objects including text boxes, shapes, and
images. The item you want to rotate is tapped. Choose the rotation handle at the
object's top, then move it in the desired direction. Choose Arrange > Rotate > Flip
Vertical or Flip Horizontal to flip an object.

Critical Thinking
Students will do it themselves
Team Work

Students will do it themselves

Ch-6 (Programming In Scratch)

A. Fillinthe Blanks

Iz
3.
3

Light Blue Color 2. Purple
Sensing Blocks 4. Stage
Operator Block

B.  Write 'T' for True statements and 'F' for False statements

1.

s
B
3.
4.

True 2. True 3. False 4. True 5. False
C. Match the following.
Sensing Blocks Light Blue
Operator Blocks Light Green
When Flag Clicked Block In Events Blocks
Wait Block Seript Execution Stops for a specified time

D.  Answer the following questions

L.

User-defined variable: Click the "Create a variable" button in the variable palette if
the user wants to create his or her own variable with a different name. A form will
show on the screen following the click of the "create a variable block" button.
Conditional statements in Scratch decide whether a programmer-supplied is true
or false. They give you the ability to test a variable against a value or compare it to
another variable.

Sensing blocks are used to recognize and quantify the interactions between items
in a project or to track specific mouse and keyboard motions. It is color-coded blue
and is one of the nine blocks.

Variables are containers that are used to store data or information in programming
languages like Scratch or other programming languages. We can save distinct
values using variables. It could be a name, a number, or any other kind of data.
Sensing blocks are used to recognize and quantify the interactions between items
in a project or to track specific mouse and keyboard motions. It is color-coded blue
and is one of the nine blocks.
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Critical Thinking

Students will do it themselves
Team Work

Students will do it themselves

Ch-7 (Introducing MS Excel 2016)
A, Fillinthe Blanks
1. Spreadsheet 2. Calculations
3. Rows and columns 4. 1,048,576 and 16,384 columns
5. Active cell
B.  Students will do it themselves
C.  Write 'T' for True statements and 'F' for False statements
1. 1.T 2.F 3F 4.T 5.F
D.  Answer the following questions
1. Thethree features of MS Excel 2016 are:
a. Easy dataentry and sorting of data.
b. Searching and replacing data can be quick.
¢. Excel hasbuilt-in formulas and functions to do calculations.
2. Thecomponents ofa worksheet are:
. Address Bar- 1t shows the address of the active cell.

2. Formula Bar: The contents of the active cell are shown here. Dates or
formulas can be typed or edited in the formula bar.

3. Status Bar: It is present at the bottom of the Excel window. It displays the
name of the selected command or status information.

3. We can enter three types of data in a Microsoft Excel worksheet: numbers, texts,
and Formulae.

4.  Follow the steps to save a workbook:
Click on the File tab.
Select the option Save or Save As.

5. Acellis an intersection of rows and columns. It is the smallest unit in a worksheet
and text, as well as numbers, can be written in it.

Critical Thinking

Students will do it themselves
Team Work

Students will do it themselves
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COMPUTER

Ch-1()
A. 1. programming 2. Electronic signal 3. machine
4. mnemonics 5. Off-stage, On stage

B. l.machine language 2. COBOL 3.CH 4.5QL 5. Prolog

¢. 1T 2.F 3.F 4.T 5.F

D. 1.Machine Language is expressed in binary form. This language has very high speed

and very low memory utilization. But understanding it is difficult and a bit time
consuming. It is highly dependent on the machine, which is why it is also regarded
as a Low-Level language.

2. Compiler Interpreter

A compiler converts the An interpreter translates line by line, carries
programming code written out the instructions, and then repeats the

in a high-level language procedure for the remaining instructions.
into machine language.

3. High-Level Language Assembly Language
User-friendly. Symbols or mnemonic codes are used in this
Machine-independent. language in place of 0 and 1.

Machine-dependent
4. The features of the fourth-generation language are as follows:
1. High speed of execution.
2. Highly user-friendly and designed to reduce the level of programming efforts.
3. In this language, the user has to mention only the output required, while the
computer regulates the sequence of instructions that will achieve those results.
5. The advantages of learning a program are
1. It develops Analytical Thinking
2. It enhances creativity.
3. Programming develops reasoning skills.
Critical Thinking
Generation Popular Programming Languages
First Generation Languages Machine Language
Second Generation Languages FORTRAN, COBOL and ALGOL
Third Generation Languages FORTRAN, Pascal and the C-family C++
Fourth Generation Languages Perl, Python, Ruby, SQL, MatLab
Fifth Generation Languages Mercury, Prolog, OP55
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Team Work

Machine Language: This language is expressed in binary form, i.e., 0 and 1, where 0
means 'off '; this is to signify a stage where the current is not flowing in the
electronic computer units. The other stage is 1, the 'On' stage, which signifies the

current flowing within the computer circuit.

Fortran is a general-purpose, programming language that is especially suited to

numeric computation and scientific computing.

C++ is a high-level general-purpose programming language created by Danish
computer scientist Bjarne Stroustrup as an extension of the C programming
language, or "C with Classes".

Python is a high-level, general-purpose programming language.

Mercury is a pure logic programming language intended for the creation of large,

fast, reliable programs.

Ch-2 ()
A. 1. presentation 2. mathematical 3. equation editor 4. screen recording
5. liveliness
B. LF 2T 3T 4.T 5. images T
C. 1. Insert 2. Stop to save 3. Symbols
4. Sound card. microphone, speakers 5.Format tool tab

D. 1.Steps:

1. Click on the Insert Tab.

2. In the images group, click on the photo album drop-down menu.

3. Click on the New Photo album option. The Photo Album dialogue box appears.

4. In the insert picture from a section, choose the File/Disk tab to select pictures
from vour computer. The Insert New pictures dialogue box appears.

5. Browse and navigate to the desired location to select as many as you want, to
make your photo album. Under the pictures in the album box, the pictures that
you select will be added.

6. Now, go to the Album Layout section and select picture layout, frame shape and
theme accordingly.

7. Click on create button. Your photo album presentation is ready.

2. Follow the given steps to insert a video clip onto a slide.

Steps:

1. Click on the Insert tab.

2. In the Media group, click on the video drop-down and select the This PC option.

3. The insert video dialogue box appears. Navigate to the location and select the

desired video, then click on insert.

4. Once the video is inserted, you can change the video shape, border effect, styles

and much more in the video Format option.

5. Click on the Play button below the video clip.
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Follow the given steps to move videos on a slide.

Steps:

1. Select the video.

2. Move the video by dragging it to the new location or press the arrow keys to move the
video by small amounts.

You can quickly include mathematical equations in your presentation by using the ink
equation tool.

Screen recording is one of the features of PowerPoint which allows recording computer
screens with audio. Follow the given steps for adding a screen recording in
PowerPoint.

Steps:

1. Select the slide where you want to record the screen recording.

2. Click on the Insert taband in the Media group, click the screen recording option.

3. Click on the select area button.

4. Drag the mouse over the desired region of the screen you want to record.

5. Click on the record button if you want to add audio to the recording.

Critical Thinking

Follow the given steps to resize the video on the slide.

Steps:

1. Select the video.

2.Resizing handles appear around the border of the video. 3. Drag any corner in or out
as per the requirement.

Teamwork

Students will do it themselves

Ch-3()

I.Backspace 2. formats 3. AutoFill 4= 5. arrow
1.T 2.F 3.F 4.T 5.F
1. Home 2.Alt+Enterkey 3.Ctrl+Spacebar 4. Arrow Keys
5.EditMode
1.

Page Up Page Down
To move one screen up, we can To move one screen down, we can
press the press the
Page Up key. Page Down key.

The AutoFill feature fills in a series of data in your worksheet automatically.

The end key will move the insertion point to the right of the cell content if edit mode
is on.

Follow the given steps to edit a cell in the worksheet. Steps: 1. Click on the cell you
want to edit. 2. Double-click in the cell or press the F2 Key. 3. Erase the cell data. 4.
Type the new data. 5. Press the Enter Key.

There are two methods to copy a formula: the Fill Handle, Copy and Paste.
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Critical Thinking

AutoFill feature automatically fills a series of data in your worksheet. Follow the
given steps to create a list using an auto-fill feature. Steps: 1. Enter the first two
values you want to start the series with. 2. Select both the cells in which you have
entered the data. 3. Position the mouse pointer over the bottom right corner of the
last selected cell. Observe how the pointer changes to the (+) sign.4. Drag the mouse
to where you want the series.5. Observe the cells filled with the desired values.
Team Work

Students will do it themselves

Ch-4()
A, l.Relationship 2.Three 3. Arithmetic 4. address
5.relative and absolute
B. LF 2.T 3T 4T 5T

C. 1.Functions are predefined formulas in Excel to perform simple and complex
calculations. Functions eliminate the chance to write incorrect formulas.
2. Acell reference is a cell address that can be used in a formula to denote a specific cell.
3. Symbols that mention the operation to be performed
4. Numbers or text values that do not change.
5. Anexpression that compares two or more numbers, text strings, cell contents, or
function outputs is known as a comparison formula.
D. 1.Enter Mode: This mode appears when you type the equal sign to begin the formula. It
is the mode you use to enter text
PointMode: When we press any navigation key on the keyboard, Excel enters Point
Mode. This is the mode you use to select a cell orrange as a formula
operand.
Edit Mode: Excel enters Edit modewhenwe pressthe F2 key. This is the mode you use
to make changes to formula
2. Whena formulais copied from one cell to another cell, the value in the copied cell
automatically gets changed.
3. Rulesto EnteraFunction
+ All Excel functions must begin with =sign.
» The function name must be a valid Excel name.
+ Open and close parenthesis must be placed after the function.
- Arguments must be enclosed in Parentheses.
4. Follow the given steps to calculate the average.
Steps:
1. Click on the cell where you want to place the average of the values. Letussay C11
Sheet 1.
2. Select the Insert Function button on the Formulas tab to open the Insert Function
dialogue box.
3. Select Average from the list box, and click on the Ok button.
5. Amixed reference is a combination of relative and absolute references. Either a row
orlocked by preceding it with a dollar symbol.
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2. The pen block presents as an extension to the Scratch 3.0
3. Thedifferent blocks available in Scratch are Sound Block, Motion Block, Control
Block, Events Block, and Pen Block
4. 1. Click the sound block.
2. Select the play sound meow until done and drag this block and place it under the
Script Palette.
3. Run the code by clicking on the blocks in the Script area.
4. To stop all sounds being played on all sprites, use the stop all sounds block.
5.Follow the given steps to choose a backdrop for the sprite.
Steps: 1. Click on the Choose a Backdrop button.
2. Choose a Backdrop window appears.
3. From the preview list, select the Blue Sky backdrop. The Blue Sky backdrop at
the background of the Sprite will be added.

Critical Thinking
Students will do it themselves
Team Work
The students will do it themselves.
Ch-5 ()
1. programming 2. pattern 3.Computational thinking
4. patterns and sequences  5.reasoning
I.F 2.F 3T 4 F 5T
1.Decomposition 2. Pattern recognition 3.Pattern Abstraction

4. Algorithm design 5. Computational thinking

1. Computational thinking is the process of breaking down a problem into simple
enough steps.

Computational thinking logically segments a problem into smaller segments, Itis a
method of problem-solving that aids the user in comprehending, interpreting, and
resolving issues.

There are four key skills in computational thinking: | Decomposition 2Pattern
Recognition

3 Pattern Abstraction 4 Algorithm Design

Algorithm design is the process of laying out the steps and rules that must be followed
in order to achieve the desired result.

The process of pattern identification is crucial in computational thinking since itallows
the user to find solutions more quickly. Once a problem is broken down, discovering
patterns in the broken parts simplifies work.

Critical Thinking
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Team Work

The students will do it themselves.

Ch-6 ()
A. 1.open-source 2. Internet 3.two 4.Individual 5. Title Bar
B. 1T 2T 3.F 4.F 5.F
€. 3 4 2 5 1
D. 1.Pythonisanopen-source programming language, which implies that anyone who is

versed in Python is capable of creating new programs and adding them to the available

Python libraries.

2.The features of Python:

e  Pythonis freely available on the internet and can be easily downloaded from www.
Python.org.

e Python is portable and platform-independent means it can run on various
operating systems and hardware platforms.

3. Thecomponent ofthe Python Window:

e Title Bar: The names of the application and the document are displayed here.
Command buttons like Minimise, maximise, restore and close are presented here.

e Menu Bar: Various tabs such as File, Edit, Shell, Debug, Windows and Help are
displayed here.

e  Script Area: The area where you type the code. Status Bar: Current status of your
cursor is displayed here.
4. Thesteps touse the script mode in Python:
1. Start Python IDLE.
2. Click New on the File menu.
3. Type the commands in the window that opens.
4. Click on save on the File menu,

5. Name the file with the .py extension.

5. Interactive Mode Script Mode
Interactive mode is where you type Script mode is where you put a bunch of
commands and they are immediately commands into a file (a script), and then
executed. tell Python to run the file.
Critical Thinking
1. Script Area 2. Title Bar 3. Status Bar 4. Menu Bar
Team Work

1. Python Developed by Guido van Rossum
2. JavaScript developed by Netscape

3.  C++ developed by Dennis Ritchie

4. PHP Developed by Guido van Rossum
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Ch-7()

A.  1.Hypertext Markup Language 2. Tim Berners-Lee 3. independent
4. Tags 5. Attributes
B. LF 2.F 3.F 4.F 5T
C. 1.Tags 2.Markup Language 3.HTML 4. markup tags
5.Block Level Tags
D. 1.The HTML fileis a text document that contains markup tags. The markup tags
instruct the web browser on how to display the webpage.
2. Container Tags, Empty Tags, Block Level Tags, Text Level Tags
3. Inorder to write HTML codes, we need to abide by some rules. These are:
1. Tags should always be surrounded by angle brackets. <>
2. Values given to the attributes should be enclosed in double-quotes.
4. The three terminologies related to HTML: Hypertext, Markup Language. Tags
5.Empty Tags: A tag that only contains an open tag and no closing tag is called an Empty
Tag. For Example: Eand many more.
Critical Thinking
1 2
3 [E N
3l H|T (M 4|C|O|D|E
¥ P 5 H
R E
E ¥ A p
R G A
T s| Bl
71 TIE(X|T
il
Team Work:
1. www.youtube.com-c++
2. www,google.com-PHP
3. www.facebook.com- Python
4. www.twitter.com-Java
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Ch-8()
1.Al 2. machine learning 3.Weak Al and Strong Al 4.first  5.Robots
1.F 2.T 3.T 4T 5.F
1. rote learning 2.SHRDLU 3. Perception 4.Voice Assistant
5.Face Detection
1. The intelligence demonstrated by a machine is known as Al

2

Weak Al Strong Al

Weak Al,alsoknownasnarrow Al isartificial | Strong Al is widely used, and the scope is
intelligence with limited functionality. vast.

It is good at specific tasks. It has incredible human-level intelligence.

3. Avoice assistant is a kind of Al software that can comprehend and carry out human
spoken orders. Examples: Google Assistant, Cortana, Siri and Alexa. Face detection is
an Al technology used for various purposes. We use face detection for filters on the face
while taking pictures and face ID for unlocking the phone.

4. Worldwide, businesses and organisations invest a significant amount of money in
customer care and putin a lot of effort to give their clients ongoing assistance. Many
companies have built chatbots to provide customer support that use Natural Language
Processing to answer questions about their products and services.

5.1.Banking and Financial Systems: Banks and other financial organisations create
Smart Apps to assist consumers with check deposits, fraud detection, etc., using Al
technologies.

2. Space Research: Artificial intelligence facilitates satellite communications and
extracts the maximum value from the images, increasing our understanding of space.
Critical Thinking

Navigation apps, estimated time, Google Maps

TeamWork

Al helps students get personalised answers to relevant questions from teachers. Italso
helps educate students according to the issues and questions they face in class materials
and online sessions, Students now have access to a larger system for interacting with

professors.
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Ch-9()

A, 1.E-mail 2.Voice-Over-Internet Protocol 3. video conferencing
4. Network Etiquettes 5.Cheques
B. 1.T 2.F 3T 4T 5T
C. 1.Netiquettes 2.VoIP 3. social networking website
4 E-Greetings 5.Facebook
D. 1. hisrefers to fraud in which scanners are used to steal the electronic serial numbers of
cellular phones, which can be utilised for billing purposes and making broadcast calls.
2. Cyber security is the practice of defending computers, servers, mobile devices,
electronic systems, networks, and data from malicious attacks.
3. E-mail, Video Conferencing, Voice-Over-Internet Protocol (VoIP), and social3
networking are different types of communication techniques.
4.
E-greeting Paper Greeting
E-greetings are in soft copy Paper greeting cards are in hard copy.
5.Data diddling, phishing, and cloning are three types of cyber threats.
Critical Thinking
AlHI(E/IB/A/IN/K|I|N/G/O I |P
RIB|C|A[S|D|F|G|O(H|J|K
e
D F|D|E||C|V|IB|[NIM|A|P|V|S
clo|Mm[M[u[N[I[Cc|A|[T]I]|O|N
Q|E|[E|A||R|T|[Y|Y|J|F|[V]I
SID|F|I|]|G]|O FIG|IK|L|P|D
Q|W|E|U|E|[GIR|E|E|T[I[N][G)
Team Work
Students will do it themselves
10 Computer - 6



"OMPUTER

Ch-1 (Advanced Features of Excel)
Upskills your intelligence
A. 1.worksheet 2. chart 3. x-axis 4. plot 5. filter
1.F 25T 3.F 4. F 1 &
C. 1. Elements ofachart:

=

ChartArea: All the area and other objects of'a chart are included in the chart area.

Data Series: Data series consists of the bars, slices, lines or additional elements that
show the data values.

Legend: Colours, patterns, or symbols assigned to the data series are depicted by
legends.
(Note: Students can write any three elements of'a chart)

2. Filtering: Filter temporarily hides some of'the data in a table, so you can focus on the
data you want to see.

3. Steps tosort data:
1. Select the range of cells containing the data to be sorted.
2. On the Data tab, in the sort & filter group, click on the sort option to open the sort
dialogue box.
3. From the sort by drop-down list, choose the column which you want to sort.
4. Select the values option from the sort on the drop-down list.
5. From the order drop-down list, choose the order of sorting- largest to smallest
option.
6. In the Sort dialogue box, click on the Add Level button to add a new level below
the first level.
7. Specify the column name as mentioned in the sheet by drop-down list and order of
sorting as A to Z in the Order drop-down list in the new level.

4. Difference between sorting and filtering:

Sorting Filtering

1. Sorting helps you organise data. 1. Filtering temporarily hides some
of the data in the table.

2. Ithelps in sorting text in 2. Itdoesnothelp in ordering a text.

alphabetical, numerical,
oldest to newest or newest to
oldest order.

3. Sorting does not enable the hiding 3. Itenables you to focus on the data of

feature. your choice.
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5. Steps to change the title of a chart:
1. Click on the chart title.
2. Right-click on the chart title placeholder; the pop-up menu will appear.
3. From the pop-up menu, select the edit text option.
4. Add the new chart title and press the ESC key.
Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.

Ch-2 (More on Python)
Upskills your intelligence
A. l.syntax 2. syntax 3.red 4. underscore, alphabet 5.input
1.T 2.F 3T 4. F 5T

C. 1. Syntax is the collection of guidelines that must be followed while writing
programming statements.

w

2. Variables are places in a computer's memory where values can be stored. These
values are retrieved from memory during processing, where they are subsequently
processed to produce output. Each variable has a set of values and distinctive names.

3. Guidelines to be followed while naming variables:

(I). Anunderscore (_) oran alphabet can begin a variable name.

(11). White spaces are used to create variable names.

(i1i). The names of variables can be made up of letters, numbers, and underscores.
(1v). A variable name needs to make sense.

4. The input function is used to receive user input. The input function is used to collect
values from users and save them in a variable.

5. Keywordsin python:

False, class, return, true, def, for, lambada, nonlocal, while, assert, break, etc.
Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.

Ch-3 (Big Data)
Upskills your intelligence

A, l.trail 2.33 3. Healthcare 4. Data Science 5. Explore
B. 1LF 2T 3.F 4. T 5.F
C. 1. Bigdatais a term which is used to denote a collection of large and complex datasets

which require expert algorithms and high-end computing devices to process data in
real time.

2. Three v's of Big data:
Volume: Mobile users use a variety of apps, which creates a large volume of data.
This data consists of their choices and searches related to different types of products,
prices, and brand preferences.
Velocity: The generation of data at a high speed is called data velocity. It doesn't only
generate data but also involves accessing and processing data ata higher speed.

Computer - 7 3



Variety: The various sorts of data produced by users are referred to as variety. Both
structured and unstructured data can be produced.

[¥S]

. The amount of data shared worldwide using some popularapps ina day:
(1) Google: 3.3 billion search queries in a day.
(ii) Facebook: 1.82 billion people log on to Facebook daily.
(iii) Youtube: 30 Million videos are watched on youtube daily.
(1v) Snapchat: 4 billion snaps are shared on Snapchat every day.

4. Data science is a multidisciplinary area that uses mathematical, scientific, and
statistical techniques to generate and extract data.

The data science life cycle

& 20 S E

OBTAIN EXPLORE

5. Companies are able to secure credit card transactions with the help of big data. It is
used by credit card companies to track transactions. Credit card companies have
access to location and transaction information from all around the world and can
easily detect any transaction fraud.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-4 (Machine Learning)
Upskills your intelligence

A. 1.human 2.software 3. statistical 4. Labelling 5. Supervised
B. 1. Environment 2. Adaptation of an animal
3. Pictures labelled in the computer 4. Digital footprint 5. Statistics
C. 1. Machine learning refers to the evolution of software used to carry out artificial
intelligence-related tasks.
2. Thedisciplines of machine learning are as follows:
(1) Statistics (11) Psychological models (1i1) Evolutionary models
3. Machine learning is important to improve the ability of a machine to assist people
more effectively in different tasks.
4. Types of machine learning:
(i) Supervised learning (ii) Unsupervised learning
(1ii) Reinforcement learning
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5. Difference between supervised and unsupervised learning:

Supervised learning Unsupervised learning
1. Supervised learning refers tounder- | 1. Unsupervised learning refers to
standing, learning, and adapting with understanding, learning, and adapting
proper guidance. without any guidance.
2. Labelling of data is the first step, 2. The computer must determine the
after which you train the computer most accurate way to carry outa
torecognise various sets of labels specific task.

with the aid of algorithms.

3. ltisachieved using the data that we 3. The machine receives input data
have collected. and must look for hidden patterns
in order to anticipate the output.

Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.

Ch-5 (Threats, Crimes and Safety in Computing)
Upskills your intelligence
A. l.cybersafety 2.antivirus 3, Phishing 4. Trojans 5. Juice Jacking

B. 1. Cyberbullying 2. Cyber Stalking 3. Impersonation
4. Flaming 5. Information Technology Act, 2000

C. 1. Staying safe and secure online is considered cyber safety. This is accomplished by
making sure that online-available personal data is secure and safe.

2. Forsafe browsing on the internet, we must do the following:
(1) We should update programmes like antivirus software and reset security settings.
(ii) Use secure and distinctive passwords.
(11i) Only download software and tools from reliable websites.
(1v) We should be cautious before clicking on links in emails, chats, and social media
postings.

3. Types of cyber threats:

Phishing: It is the sending of emails to trick a recipient into handing over money or
sensitive personal information like their bank account details or a username and
password.

Flaming: It refers to sending hatred or rage messages electronically.
4. Il effects of cyberbullying:
(i) Anxious thoughts (ii) Depression (11i) Being absent from class
(iv) Experiencing loneliness  (v)lack of confidence
5. Tips to avoid bad gaming habits in children:
(1) Playing outdoor games with friends.
(i) Taking a family trip to historical or cultural sites.
(1ii) Putting yourselfon aregular digital detox.
(iv) Enhancing emotional intelligence and self-awareness.
(v) Engaging in charitable work or volunteering activities.
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Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.

Ch-6 (More on HTML)

Upskills your intelligence

1.
4.
1.
4.
I

<tr> 2. Table 3. Number
Pixel 5. Colspan 6. Centred
<dl> 2. Table tag's border attribute 3. <tr>
Rowspan 5. Link

Attributes oftable tag:

(i) Border (it) Height and width attribute (ii1) Cellpadding

(iv) Colspan (v) Rowspan selector

. A'border can be specified using the table tag's border attribute. A number is required

for the border attribute.

. Cellpadding is the appropriate attribute if you want to modify where cell data is

placed in relation to the borders of the cell. Sometimes we wish to position the cell
data that it is farther from the cell borders for better clarity. This improves the
readability of the table's content.

. The function of <th>tag is to define a cell header foran HTML table. The cell header

is boldly displayed and typically centred.

. Both <tr> tag and <td> tag are different from each other. The <tr> tag in HTML can

be used to construct a table's row while a table's cells are created using the <td> tag.

Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.

Ch-7 (Cascading Style Sheets)

Upskills your intelligence
1.CSS 2. Cascading Style Sheet 3.0nce 4. Syntax 5.HTML

1

. CSS Font-face 2. Selector 3. RGB
4,

L

CSS Font Face family name 5. Background-image: url(*image name™);

As CSS stylesheet code needs to be written once, it means the actual code a browser
has to work on is less. The page will download more quickly if there is less code.

. Like all other languages, CSS has a syntax of its own. The syntax is a set of

guidelines used when writing code in a certain language.
Example:

H1 {color: yellow; font-size: 1 px;}

. A CSS code consists of three important elements- selector, +the help of CSS Font,

and the text's font style can be altered. In CSS, changing the font style can be done in
one ofthree different ways.

(1) By only entering a colour's name as a value.
(i) You can utilise predetermined hexadecimal colour values.
(i1i) Use the RGB colour code.
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5. There are two types of font-family names in CSS which are defined below:
Family name: [tis the name of'a family of fonts that includes “Arial.” “Times,” etc.
Generic- family: It is the name of the generic family that include five categories,
which are “serif,” “sans-serif,” “cursive,” “fantasy,” and “monospace”.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-8 (Conditional Statement in Python)
Upskills your intelligence

A. l.userID, password 2. Control 3. cause, effect 4. If statement 5.1f
1.F 2.F 3T 4.T 5.T
C. 1. Syntax ofifelse statement:

if<condition>

Statement(s)

w

else:
Statement(s)
2. Working of the if statement:

(1) The simple If statement tests a condition and if it is true, performs some steps,
otherwise it does nothing.

(ii) If the condition is true, it performs the result, but if it is not true, no error message
will be displayed to the user.

3. Syntax:
if<condition1>
Statement(s)
elif<condition2>:
Statement(s)
else:
Statement(s)
4. Ask students to do it by themselves.

5. The second block is an else block. This block contains the statements which will be
executed if the value of the test expression becomes false

Family name: Itis the name of'a family of fonts that includes “Arial,” “Times,” etc.
Generic- family: It is the name of the generic family that include five categories,
which are “serif,” “sans-serif,” “cursive,” “fantasy,” and “monospace”.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-9 (Computer Virus)
Upskills your intelligence

A. l.virus 2. humans  3.virus  4.aworm 5.Nimda
B. 1. Antivirus 2. Mcafee 3. Slammer
4. Trojan Horse 5. Zero Access, Zeus, Beast
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1. Computer viruses are small software applications that are created with the intention

of'spreading from one computer to another and interfering with computer functions.
A computer virus can damage important data from your computer, and also harm the
computer system.

. Signs of being infected by a virus

Your computer begins to operate more slowly than usual.

Your PC frequently stops.

Application programmes begin acting strangely or can abruptly shut down.
You are unable to access your disc drives or data.

The computer becomes unresponsive or hangs up.
e Shortcuts can be created for files and directories, and file sizes can alter,

3. A Trojan horse is a program downloaded and installed on a computer that appears

harmless, but is, in fact, malicious. The user is usually tricked into opening them
because they appear to be genuine software or files. It usually spreads with email
attachments and removable hardware devices.

. Computer viruses are frequently transmitted by attachments in email or instant

message conversations, as well as through portable storage devices like pen drives
when they are connected to the computer.

When you download anything from the internet, viruses can be concealed as
attachments of amusing photos, greeting cards, or audio and video files.
5. ® Acomputer virus might corrupt or delete data on your computer.

e Itcanuse youremail program to spread itself to other computers.

e Itcanevenerase everything on your hard disk.

e Viruses can harm the computer by destroying the files and finally crashing the
system.

Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.
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Ch-1 (Computer Network)
Upskills your intelligence

A.  1l.modem 2.hardware 3.phishing, datatheft 4.size, purpose 5. geographic
0 R i 3T 4. F ST

C. 1. An organisation can benefit greatly from a computer network in a number of ways.
Here are some advantages of a computer network.

w

(1) Saves cost (ii) Reduces data redundancy (iii) Sharing resources (iv) Security

2. Local Area Network: The Local Area Network is confined to a limited area, such as

a room, an office building, etc. As the area covered by LAN is limited, the data
transmission speed in LAN is very fast.
Metropolitan Area Network ( MAN): A metropolitan area network consists of a
computer network which covers an entire city. As compared to LAN, it covers a
wider area. ATM machines of a specific bank, installed at different locations in a city,
are an example of MAN.

3. The network topology is an organisation of diverse network components in a way
that makes communication simple and easy. Before you start with the arrangement
ol network components, [t's crucial to establish the logical topology—also known as
the information flow between network components.

4. In Client-Server Network, several Computers called clients are connected to the
main computer called the server. A computer that serves clients and manages access
to hardware, software, and other resources is known as a server. The computers that
ask the server for services like data retrieval, storage, etc. are known as clients.

5. Wide Area Network: A wide area network occupies a very large area, such as an
entire country or the entire world. It consists of many smaller networks, such as
LANs or MANs. The primary characteristic of WAN is that data transfer requires a
public telecommunications medium. A very common example of WAN is the
internet, wherein millions of computers are interconnected with each other.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-2 (Log on To Access)
Upskills your intelligence

A. l.advanced 2.decision-making 3. Databases 4. storage location

1.T 2.:F 31 4. F I

C. 1. Microsoft Access is the most popular and powerful (RDBMS Relational Database
Management System) that serves as an integral part of the Microsoft Office Suite
Application. It is employed to effectively organise and manage massive amounts of
data.

=
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2. Components of Microsoft Access 2016:
Title Bar: The name of the current database is displayed on it, at the top of the
window.
Quick Access Toolbar: This is found in the Access window's upper left corner. It
comes with three buttons by default: Save, Undo, and Redo.

Ribbon: It has numerous tabs, each of which has a number of groups of relevant
commands. Such tabs are called Contextual tabs.

Status Bar: On the extreme left, it displays the name of the current view and on its
right, it displays four view buttons, which are Datasheet view, Design view,
PivotTable view and PivotChart View.

Object Tabs: It displays the elements you've opened in tabbed form. The contents of
the components in the Work area are displayed when you click on any tab.

3. Stepstocreate a blank database.
Step 1: Click on the Blank database option.
Step 2: In the file, the name field enters a name for the database.
Step 3: Click Create.
4. Creating a Table In Design View:
(1) In the Field name, add a column name for the table.
(11) Select an appropriate data type for the field from the Data Type drop-down list.
(111) Add the text in the description to enter a few more details about the field.
(iv) Save the table by clicking on the Save option in the File tab.

5. Primary key is a standard feature of every database management system which is
used to identify each record of a table uniquely. The field which is designated as the
Primary key of a table neither can have duplicate data nor it can be left blank while
entering the data.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-3 (Working with Queries, Forms and Reports)
Upskills your intelligence

A. l.sequential 2. form 3. operational
4. Navigation 5. A form's record navigation bar
B. L.T 2.T 3T 4.F 5:T

C. 1. A form is a device for gathering data in a sequential style. Frequently, whoever
creates the form has all the necessary fields for the required data.

2. Waysto Formata Form:
(i) Changing Themes and Fonts of a Form
(11) Inserting Date and Time to a Form
(1ii) Arranging the Order of the Fields in the Form
(iv) Adding a Background Image to a Form
3. Stepsto create a form:
(1) From the Navigation Pane, choose the table.
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(i1) Click the Form button in the Forms group after selecting the Create tab from the
ribbon.

(iii) A new form has been created; notice how the ribbon's options have changed and
how the Design tab is now active.

(1v) Click the Home tab and then the view button displayed in the Views group to
input or edit records in the form. Go to the drop-down menu and choose Form View.

. Creating Query with Query Wizard:

(1) Select the “create” tab. In the Queries group, click the Query wizard button.

(11) The New Query dialogue box appears. By default, the Simple Query Wizard
optionis chosen. Click OK to continue.

(iii) As illustrated below, the wizard will now ask us to choose the query table and the
fields inside it that we want to include in the query.
(iv) We will be asked to enter the query title in this final step.

. A report is a useful tool for organising and summarising data which can be created

exactly the same as we have created the form.
Areport can be created exactly the same as we have created the form.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-4 (Cloud Computing)

Upskills your intelligence

A. 1.subscription 2. email 3.Small 4. storage 5. private cloud
B. LT 2.F 3T 4. F 5:T
C. 1. Cloud computing is a service that requires a subscription and includes a number of
services. These services are used by individuals and organisations. Because all of the
processes take place in the internet world, it is known as cloud computing.
2. Different types of cloud services are available depending on the needs of the users.
(i) Public Cloud
(i1) Private Cloud
(111) Community Cloud
(iv) Hybrid Cloud
3. Thedisadvantage of Cloud Computing
e We have little to no understanding of where our data is stored, and we have
limited control over who has access to our information.
e Ourdatais frequently accessed by hackers without our permission.
4. The following considerations should be made by a user before choosing a cloud
service.
o Whatkind of encryption does the provider use?
e What methods of protection do they have in place for the actual hardware that our
data will be stored on?
e Do they have duplicates of our data on hand?
e Do they have firewalls setup?
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e What safeguards are in place to prevent a user's information from being shared
with other users if they have a community cloud?

5. Dropbox: One of the best cloud services for sharing files is Dropbox. It offers its
customers SaaS-based services.

Google GSuite: The most widely used email application in the Google Play Store is
Gmail, a free online email service.

Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.

Ch-5 (Introduction To Arduino)
Upskills your intelligence

A. l.integratedcircuit 2. input 3.microcontroller 4. digital 5. code editor
I.T 2.T 3T 4. F 5.T

C. 1. A microcontroller is a compact integrated circuit designed to govern a specilic
operation. A typical microcontroller includes a processor, memory and input/output
(L/O) peripherals on a single chip.

w

2. Partsof an Arduino
Built-In LED: Whether your Arduino is delivering or receiving data is indicated by
the LEDs labelled TX and RX.
Digital I/O Pins: The holes on this side of the board are called the digital input/
output pins. They are either used to sense the outside world (input) or control lights,
sounds or motors.

3. Analog Pins: Instead of providing a simple on/off signal, these pins take sensor
measurements throughout arange of values.

4. IDE stands for Integrated Development Environment. It's a coding tool which
allows you to write, test, and debug your code in an easier way.

5. Difference between an Arduino and a normal computer:

Arduino Computer
1. The Arduino is a programmable 1. Acomputeris amachine oradevice
microprocessor/microcontroller. that performs operations based on

instructions provided by a software
or hardware program.

2. The Arduino can perform only one 2. Acomputer can run multiple
oraspecific program. applications.

Critical thinking: Ask students to do it by themselves.
Team work: Ask students to do it by themselves.

Ch-6 (Looping Statements in Python)
Upskills your intelligence

A. 1.condition 2. three 3.traversal 4. infinite 5. Continue Statement
B. 1. While Loop 2. While Loop 3. Traversal 4. For Loop 5. Break Statements

Computer - 8 5



C. 1. The idea of a loop enables us to execute programme instructions repeatedly without
having to repeatedly write the same ones. The successful execution of the loop
depends on the condition.

For Example, Mother gives you a bowl of rice. You won't eat it up at once. You start
with the first spoon, then the second and so on. In this manner, you finish your rice
after several tablespoons of eating.

2. If a condition never evaluates to FALSE, a loop becomes infinite. It occurs because
the loop either lacks a terminating condition or has a requirement that can never be
satisfied. Asaresult, anever-ending cycle is created. [t is known as an infinite loop.

3. Difference between for loop and while loop:

Forloop ‘While loop
1. The for loop is used to repeatedly 1. Inthe while loop, if the specified
iterate over a sequence's values. condition is true, a series of
statements will be carried out.
2. The 'forloop'is also called a 2. It'sreferred to as a conditional loop.
counting loop.

4. Askstudents to do it by themselves.

5. Continue Statement: This command causes the loop to skip the remaining portions
ofits body and to retest its condition right away before updating the loop variable.
Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-7 (Robotics)
Upskills your intelligence

A. l.artificial intelligence 2. bionic prosthesis 3. Sensors
4. hazardous, dangerous 5. Robotics
B. 1LF 2. 3F 4T 5.F

C. 1. Robots are artificial agents that behave in the real world. They can carry out the tasks
that a person gives them. Robots are equipped with sensors that can recognise and
pick up on physical information from the outside world, such as heat, light,
temperature, pressure, sound, bumps, and movement.

2. Features of a Robot:

e A robot absorbs information about its surroundings and makes use of that data to
carry out tasks as directed.

e [t functions according to the programs installed in it and the programs can be
changed accordingly.

e Robots have sensors which enable them to see even in dark as well as detect the
small movements which anormal person is not able to do.

3. Types of Robots:
(1) Aerospace Robots (11) Consumer Robots

(iii) Disaster Response Tools  (iv) Industrial Robots  (v) Medical Robot
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4. Applications of robotics:
e Conservation: fighting forest fires.
Manufacturing: working in factories, finding and carrying items in warechouses.
Companionship: providing company to elderly individuals.
Healthcare: assisting in surgical procedures.
Delivery: completing food delivery and last-mile fulfilment.
Household: vacuuming and mowing the grass.
Rescue: undertaking search-and-rescue missions after natural disasters.

Military Operations: detecting landmines in war zones.

5. Robots used in disaster response do hazardous or dangerous duties.
Robots are widely used in manufacturing, assembly and packing.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-8 (Cyber Ethics)
Upskills your intelligence
A. l.computerethics 2.unauthorised 3. Hackers 4.important 5. False
LT 2.F 3T 4. F 5./L
. Cyberstalking is the recurrent practice of unwanted monitoring or harassment with

the intent to manipulate or influence the victim. Online and offline stalking are both
against the law.

o w

2. Identity theft is a type of cybercrime in which the culprit creates a false identity in
order to obtain financial benefits like credit cards and loans, among other things.

3. Spamming involves sending the same messages to email users all over the world in
millions. Since spam may be used to spread malware such as trojan horses, viruses,
worms, spyware, and coordinated targeted phishing attempts, it poses a major
security risk.

4. Some points to keep in mind while accessing a website:

o When using the websites, use common sense.

e Verify the website's address, contact information, and email address to ensure its
legitimacy.

e The URL of the website might look authentic. Keep an eye out for slight spelling
variations.

e Use the most recent versions of your browser and antivirus software.

e Always keep in mind to log out of the website after finishing your transaction.

5. Any computer that is connected to the internet is exposed to a wide variety of
technological dangers. Cyber security tries to protect sensitive data, computer
security, confidentiality, integrity, and accessibility of important data kept on
computers.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.
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Ch-9 (Introduction to App Development)

Upskills your intelligence
l.operating  2.native
1.F 2.

3. design

2T 4.T

1. Difference between Native and Web apps:

4. operating system 5. Web

5.F

Native

Web apps

1. Native apps are created expressly
foran operating systemona
mobile device.

1. Appsthatcan be used with a web
browser are referred to as web apps.

2. Take up much space in the device.

2. Itdoesn't occupy space in the device.

3. Itis expensive to maintain.

3. Ttis easy to maintain.

2. Choosing the right app: Apps are chosen according to the following features.

(1) Development Time

(i1) Limited Resources

(iii) Performance

3. Thunkable is a web-based application that was first made available by Google and
has an integrated development environment, Anyone with basic computing skills
can develop Native apps that are based on Android and i0S.

4. Creating App with Thunkable:
Steps:

(1) Seroll down to the Image tool in the design section.

(i1) Place the picture tool in the Layout Screen by dragging and dropping it there.

(1ii) Choose a picture from the Image panel on the right side of the screen. Utilise the
Upload files option to upload an image from your PC.

(1v) As soon as the picture has been added to the layout screen. On the Layout Screen,

you can drag and drop it to reposition it.

(v) Scroll down and choose the Label tool in the Design section. Drag it down and

drop it next to the picture.

(vi) From the labell panel shown on the right-hand side of the browser screen, click
on the Text option and add text of your choice in the textbox.

(vii) Seroll down and choose the button tool in the Design section. Drag it down and

drop it just below the label.

(viii) From the button panel, click on the text option and add the text of your choice in

the textbox.

5. Web apps and native apps are combined to create hybrid apps. These apps can be
loaded on a device much like native apps and have a user interface similar to a web
app. Apps that are hybrids can be acquired from the 108 or Play stores.

Critical thinking: Ask students to do it by themselves.

Team work: Ask students to do it by themselves.

Ch-10 (Sound Editing With Audacity)

Upskills your intelligence
1.28.2000
L.F

2. user-friendly

2T 3K 4.T

3.zoom

4. Combining
5.F

5. Import

8
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C. 1. Audacity is a free open-source programme that enables you to edit and record audio.

Audacity was released on May 28, 2000,

2. Audacity is a free open-source programme. The most recent version of Audacity is
readily available online.
Open the browser application on your computer and type the URL displayed below
in the address field to download Audacity. www.audacityteam.org

3. Audacity is a cross-platform app, that allows you to install it on devices running
Windows, Linux, or Mac OS operating systems.

4. Steps to import audio to Audacity.
(1) Select Import from the menu selections by clicking on the File menu, and then
choose the Audio option.

(ii) Find the track you want to import in the select one or more files dialogue box.
When the desired track has been chosen, select Open to bring it into Audacity.

5. (1) Utilizing Audacity Timeline's import function, add a track.
(ii) Choose the section of the track where the effect should be applied using the
Selection Tool from the Tools Toolbar.
(iii) Press the Ctrl-A key combination to add effect to the entire track.
(1v) Now select the Echo menu option by clicking on the effect menu. (v) The chosen
section of the track will immediately receive the Echo effect.

(vi) Using the instructions above, you can apply a variety of different effects to your
audio file.
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